Настройка VMmanager KVM (OVH IP) на Debian 7

Все таки вышло на Debian. Один чел, администратор из команды abcdteam Streser запилил на CentOS мануал. И его мануал мне помог найти ошибку какую я делал при настройке интерфейсов, а именно vmbr0.

Сервер: Intel® Xeon® CPU E3-1225 V2 @ 3.20GHz, 16 GB RAM, 3 x 120GB SSD. Заказать можно здесь: ABCVG.net
Блок IP:
193.70.18.68/30
Network IP :193.70.18.68
Broadcast IP :193.70.18.71
Gateway IP :193.70.18.70
Netmask :255.255.255.252

ОС: Debian 7.10

Диски я особо решил не делить, а сделать общий раздел, мне так проще.

Качаем:
wget http://download.ispsystem.com/install.sh


Пишем:
sh install.sh




Клацаем параметры кончено же:

b) beta version — has the latest functionality
2) VMmanager
1) VMmanager-KVM

Заходим:
If this doesn't work You can use IP instead of domain
Like: "https://94.23.12.34:1500/vmmgr"


Заходим, подтверждаем лицензию.

Создаем пользователя, vova например.



Настраиваем политики. Добавляем главный узел VMmanager.



Добавляем первую ноду как локальную.



Устанавливаем шаблон ОС.



В /etc/network/interfaces пишем в конец такой для каждого блока:

auto vmbr0:0
iface vmbr0:0 inet static
	address 193.70.18.254
	netmask 255.255.255.0
	gateway 193.70.18.254


Для нового vmbr0:1..vmbr0:n и так далее, короче.
Вот на этом моменте я застрял когда сам пробовал это настроить, а все так просто и епично.

В /etc/resolv.conf делаем такое содержимое:

nameserver 8.8.8.8
nameserver 213.186.33.99
search ovh.net


А в /etc/sysctl.conf такое содержимое делаем вместо прежнего:

net.ipv6.conf.all.autoconf = 0
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.eth0.autoconf = 0
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.eth0.accept_ra = 0
net.bridge.bridge-nf-call-iptables = 1
net.ipv4.ip_forward = 1
net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-call-arptables = 0
net.ipv4.conf.all.proxy_arp = 1
net.ipv4.conf.all.send_redirects = 0
net.ipv4.conf.default.proxy_arp = 1
net.ipv4.conf.default.send_redirects = 0


Перезагружаем сервер. reboot в консоли.

Добавляем блок IP адресов:


У вас все IP будут доступны для каждой VM. То есть если блок на 4 IP, то все 4 будут доступны.
Не надо getaway, broadcast как в OVH используются они с блока.


Создаем тестовую VPS:


Установка пошла, профит:


Windows тоже установить можно.

Буду рад донату за статью: клик. На все вопросы в комментариях будут ответы.

17 комментариев

avatar
Понял
avatar
Спасибо Вам огромное за статью.

А как сделать то же самое для блока /29? Когда прописываю, после ребута теряю связь с сервером.
avatar
/29 это 8 IP. Так же как и в конфигурации написано что getaway .254.
Все работает. Ты просто что то не так делаешь, вот и все.
avatar
Спасибо, уже разобрался. Еще вопрос, в OVH/SyS/KS необходимо генерировать МАС адрес к IP адресу. Вы в своем туториале не задавали соответствие IP-MAC, у меня работает и без привязки мака. Могут ли быть проблемы с OVH в связи с этим?
avatar
Не могут. Зачем MAC?

Это же без смысла MAC. Создается виртуальная машина и к ней придается IP через Getaway через мост vmbr. OVH IP просто очень классная вещь. Как конструктор.
avatar
Большое спасибо за пояснения. Хорошего вечера!
avatar
Делаю на шаблон от OVH, а не устанавливается.
Не подскажете, что делать?
avatar
Значит сеть неправильно настроена если ОС не ставится. Так как ОС ставится с интернета и раз сеть неправильно настроено то нету доступа до интернета и по этому оно не устанавливается >_<

Не надо винить шаблон OVH. У них шикарные сборки Linux и все пакеты есть.
avatar
Сеть настроена. Зависает на подключение узла (уже решил. ребутнул и пересобрал пакеты)
Теперь ошибка в другом. В любой ОС выводит debootstrap: Segmentation fault (или что-то похожее, но ошибка исходит от debootstrap в любом случае)
Могу я надеяться на вашу помощь?
avatar
Я не понимаю что ты делаешь. Ты настраиваешь VMmanager? Ты ставишь ОС через VMmanager?
avatar
Это при установке ОС через VMmanager.
avatar
Ну значит это проблемы через ISP и их сборки Debian.
avatar
Так вот проблема то в том, что я не знаю как до них достучаться.
Покупал лицензию у isplicense. У них поддержка 8 евро / 30 минут.
На форуме ISPsystem послали в ТП, а я же всё таки покупал не у них.
И да, на аналогичном дедике всё работает прекрасно.
Может это я кривой?
avatar
ISP перестали писать даже о OVH. И мануал о настройке VM удалили они у себя с вики.
Может плохо что то настроил. Мануал у меня рабочий.
avatar
Что мне тогда делать? Может что-то подскажете? Я всё понимаю, но я в безвыходной ситуации походу дела.
Два дня уже бьюсь над этой проблемой. На секунду один парень починил, но только для одной VM, а с другими такая же ситуация.
Трачу время в пустую. Не могу ничего сделать. Уже ставил и CentOS 6.8 и CentOS 7, и Debian 7 и всё одно и тоже.
avatar
Напиши на почту подробнее.
avatar
Забыл добавить, что при установки ОС. Установка идёт, а потом обрывается на этом моменте.
Может я что-то не правильно сделал с шаблонами?

Оставить комментарий




Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.